Krontalk

Chronos => Chronos User Discussion => Topic started by: PointyHairedBoss on May 03, 2019, 08:29:12 PM

Title: No Batt
Post by: PointyHairedBoss on May 03, 2019, 08:29:12 PM
My Chronos 1.4 arrived today & I'm having trouble charging the battery for the first time.  My first problem was installing the battery.  After reading some posts I learned that tight fitting batteries have been an issue & apparently  still is.  I bought a spare battery on amazon prior to getting the camera & was happy to see that it was identical to the one that ships with the camera. After plugging in the power cable the light came on & I assumed the battery was charging.  After 2 hours I unplugged the cord & pressed the power button but the camera did not power up. I plugged the power cord back in, pressed the power button & the camera powered up but it shows a "No Batt" message in the bottom right corner.  I tried my second battery & had the same result.
Any suggestions?
Title: Re: No Batt
Post by: PointyHairedBoss on May 07, 2019, 04:37:23 AM
Camera is being returned for warranty repair.
Damn. And just when I was ready to start breaking stuff.
Title: Re: No Batt
Post by: Fyodor on May 08, 2019, 10:28:43 PM
That way the anticipation (German "Vorfreude" - literally pro-joy) lasts longer.
Title: Re: No Batt
Post by: PointyHairedBoss on May 27, 2019, 07:17:48 PM
Update:
The battery now charges in the camera but my battery message does not always work.  Whenever the power cord is attached the battery status & voltage are displayed.  When the power cord is disconnected, sometimes the battery info correctly displays, other times the "No Batt" message appears, even though the camera continues to operate on the battery. See attached photos
Title: Re: No Batt
Post by: PointyHairedBoss on May 28, 2019, 04:41:53 AM
One other note about the batteries.
The battery / connecting prongs in the camera have some interference.  You can see in the photo where bits of plastic have sheared off where the little sockets plug into the prongs.  I've had to pick out bits of plastic from the battery sockets. I got a spare battery from Amazon which is identical to the one that shipped with the camera & both batteries are affected.