Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - NiNeff

Pages: [1] 2 3 ... 6
1
Chronos User Discussion / Re: Bad Image Quality
« on: December 10, 2018, 10:57:27 AM »
Could you post a very small sample image or video of what you are experiencing? It might be easier to help you then. Also, try to do as Nikon1 said ;D
Also: heres one of my very first videos: https://youtu.be/fsZ0ofxSuS4
Stock lenss(aperture opened as wide as possible), no settings changed, maybe not even black calibrated and a very cheap LED floodlight (similar to this one) You can see the light "flickering" as it actually changes intensity at about 50/60 or 100/120 Hz depending on design and your mains frequency.

If you can't get the image quality to be at least at that level, then there's most likely something wrong with your camera.

EDIT: here's a hint how much light you should have:
As a rough estimate, for a color camera, you'll need about 7 lux per fps at f/2 and 360 degree shutter.

So at 4000fps, you'd need about 4000fps * 7 = 28,000 lux. If you want to run f/4, you'll need 4x as much light, so 110,000 lux which is about noon day sunlight

2
Chronos User Discussion / Re: Chronos 1.4 Footage Thread
« on: December 09, 2018, 08:09:09 AM »

3
Chronos User Discussion / Re: Question about Shutter Speed
« on: December 06, 2018, 11:32:09 AM »
As far as i know, there is an Limitation on ANY Highspeed-Camera out there in the whole market, that the fastest shutterspeed must not be shorter than 1us.
There is some kind of limitation, and i was always interrested why that is... If it goes slightly faster than that on some of the Presets, i think its still kind of borderline ok for that.
If you want faster Shutterspeed, you need some kind of special permission and a good reason, why you would even need to have such a camera... (or just hack /Modify the firmware on your own...?)
.
Please dont quote me on that, this is just from what i heard other people say and as good as i could remember, i never did the acutal research myself.
.
I think ive seen someone of the Kron-Staff say here in the forum, that the chronos Camera itself ist capeable of way shorter/faster shutterspeeds per frame, but it is not enabled due to this (legal?) Limitation. If i remember correctly, the talk was about reducing the resolution to actually just a single Line of pixels at some kind of crazy framerate to create some kind of line-scan-camera. In such a mode the chronos should be able to push tons of frames (lines) per second...

#Edit: Sorry if Bad english BTW...
If there is such a legal speed limitation, it would most likely be due to ITAR. For example, thermal (IR) cameras are limited to be below 10 fps and/or 640 x 480 px to be exempt of ITA-regulations. So if you see any IR camera above those limits, the manufacturer got a specific permit from the US government to do so and the sales are very likely restricted to certain regions and so on.
Now you might say what has this to do with equipment coming from countries other than the US (like Canada ;))? Well they just claim world wide jurisdiction...

I did not search for ITA-regulations regarding regular high-speed cameras, and honestly I don't want to dig into that rabbit-hole ;)

4
Software Dev / Re: Chronos V0.3.1 Beta - Updated Oct 15 2018 with beta-9
« on: October 24, 2018, 01:54:26 PM »
re.
- Standalone daemon to operate the video system, with DBus API.
Does that mean we will get a QT app soon that runs on the PC to control the camera?
yes but not a qt app. it will be a webinterface as I understand it

5
Software Dev / Re: Chronos V0.3.1 Beta - Updated Oct 15 2018 with beta-9
« on: October 23, 2018, 10:42:50 AM »
I am trying to update from 0.2, but it seems it can't find the update. When I try to backup the calibration data, it says "Error: no device is mounted to /media/sda" and if I try to update it says "No software update found".

In the Save settings it says the save Location is "/media/mmcblk1p1 (SD Card Partition 1)". I can save clips just fine to the card and they show up in the root directory.

The card was formatted in FAT32. The update file was extracted to the root of that card.

What am I doing wrong here?
Seems like you are trying to update from a SD Card. This is not supported (yet).
You have to use the USB-Port on the side using a FAT32 formatted Stick. As mentioned above several users had issues so far. You might have to try more than one USB Stick.
Also: Don't try to use the USB-OTG port (the smaller one) use the USB / E-SATA combined one instead.

6
Chronos User Discussion / Re: Moonlit stills, Chronos suitable?
« on: October 18, 2018, 09:49:41 AM »
I was using Magnification in the sense most Binoculars are displaying it. But actually I don't quite know how that is specified then. Googling reveals "an object viewed through 10x magnification glasses appears 10x times closer" which is not the same as 10x larger one might think. Also I have a feeling there's quite a bit of marketing involved so not really a good measure.

7
Chronos User Discussion / Re: Moonlit stills, Chronos suitable?
« on: October 17, 2018, 09:31:00 AM »
The noise you're seeing here is actually just dark noise. Black cal won't work below about 60fps, so what you're seeing is an uncalibrated image. Try doing a black cal at 60fps then changing to 10fps.
That's actually what it did. I first did a blackcal an then changed the FPS. as it was very bad, I did a second black cal at 10fps with no improvement, obviously.

@nikon 1: I don't remember the f-stop settings, but it was very closed. the exposure time was also way down to about 1% The moon is indeed very bright.

@Sael: that mars video is actually really good, I guess you're using a magnification of about 250x to 300? Now I'll definitively need to hook up my telescope to the Chronos just for the fun of it

8
Software Dev / Re: Chronos V0.3.1 Beta
« on: October 16, 2018, 11:54:14 AM »
Is there something else missing from the CinemaDNG tags? Even Photoshop cannot open the files. No previews in macOS.
I'm having no trouble with the new beta 9 and Photoshop CS5 now.

9
Chronos User Discussion / Re: Moonlit stills, Chronos suitable?
« on: October 16, 2018, 11:32:41 AM »
I did some tests now using 10 fps as the "long" exposure which is still really short compared to the usual seconds or minutes normally used for astrophotography or videos.
The Chronos is not suitable at all for this task.
See the attached still of the moon. The noise is not some sort of JPEG-artifact but inherent to the camera. I tried my best to let the cam warm up and did a black cal just before this shot.
Also, here's a really blurry video of mars taken also at 10 fps:
https://youtu.be/g-L_JynwLPc

10
Software Dev / Re: Chronos V0.3.1 Beta
« on: October 15, 2018, 01:01:14 PM »
Thanks so much for the excellent feedback! We've tried to fix the reported issues with an updated the beta, please see the first post for a link to the updated camUpdate-v0.3.1-beta-9-geb319ea.zip installer package. To give a brief description of what has changed since the beta-4 package:

Notable Features:
  - Redesign of the white balance window, including a new dialog to edit the color matrix.

Minutiae:
  - Add crosshairs to the white balance window.
  - Add Qt stylesheet to improve focus visibility.
  - Main window exposure now shown in microseconds and shutter angle.
  - Jog wheel now adjusts exposure logarithmically, or by degrees when pressed.
  - The 'close' button on the soft keyboard now applies the entered text.
  - Reorganization of the soft keyboard to include a negative key.

Fixed Bugs:
  - Black ares of the UI become transparent after an HDMI hotplug.
  - HDMI hotplug while on the playback window would revert to live display.
  - Add missing ColorMatrix1 and CalibrationIlluminant1 tags to CinemaDNG files.
  - Fix possible crash of the video system when aborting a file save.
  - Fix possible carsh of the UI when rapidly aborting and re-starting a file save.
  - Fix color correction math so that saturating the image sensor tends towards white.

Also, some bugs that were introduced in beta-4 but now fixed (not mentioned in changelog.txt):
  - Monochrome TIFF now pads the pixel values with least-significant zeroes.
  - H.264 bitrate setting was being ignored and defaulting to 0.25 bpp.

Nice! I did a really quick test. the updateprocess went smooth,  the new features are there and the colored highlight really helps to select stuff with the jogwheel.
Will test it thoroughly sometime this week, especially the color stuff.

11
Software Dev / Re: Chronos V0.3.1 Beta
« on: October 12, 2018, 09:15:36 AM »
Ok now the "new" issues I found:

  • The FPS and Frame Time input fields in the Record settings behave erratically. If you enter any FPS and leave with "close", the field remains at that entered value, but does not update the "Sec" field. When then recording the old FPS value is used. If you instead change the lower "Sec" field and leave with close, the recording actually uses that corresponding framerate without updating the FPS field in the UI.
  • If you use the (kind of hidden) "Apply" button on either input field, the other one changes correctly. However it sometimes changes the order of magnitude (for example 1000 FPS to 1000000 mFPS) which is not only confusing, but also inconvenient since the magnitude "letter" is not selected for new inputs if you click on the field and has to be deleted manually.
  • If you lower the FPS rate below the current one, exposure time also gets lowered in the same rate. For example 1500 FPS to 1000 FPS lowers the exposure from 1000 S to 660 S. This is is done "quietly" and therefore easy to miss.
  • Not really something changeable, but the red "Low Battery" indication looks a lot like the "recording" light, especially in the dark. We lost one shot that way but luckily the experiment was easy to redo. And you can argue it was user error ;)
  • This might not actually be a camera/sw bug, but the produced DNGs can't be opened by my Photoshop (CS5 with CameraRaw 6.7.1). As far as I can tell it basically complains (understandably) that it is has now idea about the used Camera Model – I was however able to open the DNGs with UFRaw, so maybe there are just a few settings missing in the files or Photoshop can't actually display DNGS from "unknown" cameras at all. Probably related to the Error mentioned by JamesB

Some general improvement ideas for a possible future hardware version which surfaced during the last testing:
  • a hinged display which can be "detached" and swiveled around would be really handy
  • the recording indicator could also be useful on the front in addition to the top and back
  • while the cs mount is a great choice for size and available lenses, changing lenses via screwing is not nearly as nice (or quick) as using some form of bayonet-coupling

12
Software Dev / Re: Chronos V0.3.1 Beta
« on: October 10, 2018, 02:46:46 PM »
Nikon1 and I did quite a bit of testing together today and I think we found some more bugs. I'm going to try again sometime this week and post details then.
We also shot some amazing footage, expect some of it to show up on the forums here ;)

13
Chronos User Discussion / Re: Chronos 1.4 Footage Thread
« on: October 09, 2018, 08:52:20 AM »
What is that overlay on the Clip?
Is that done in post or can you add it in Camera already?
It can be done on the Chronos directly using the last beta software.

14
Software Dev / Re: Chronos V0.3.1 Beta
« on: October 08, 2018, 09:14:22 AM »
The offending tag in this case is in the EXIF image metadata, and should be the BodySerialNumber as defined by the EXIF 2.3 standard. It looks like the version of libtiff being used by ImageMagick only supports tags up to EXIF 2.2. I guess I should make a note to remove that tag from the TIFF format if it's not widely supported by image processing software.
The standard is now more than 2 years old, so it's not a really cutting edge feature. I therefore looked around and imagemagick indeed does not support the "new" tags yet. I therefore created an initial pull-request to add those tags. I have now idea if it will work or if it will be accepted, but at least I tried ;D
My pull-request actually got accepted and merged, so the next imagemagick version might support the "new" Tags. I'd say keep them for now!

15
Chronos User Discussion / Re: My external monitor for Chronos
« on: October 07, 2018, 07:19:16 AM »
Ahhhh thank you! ;D

Pages: [1] 2 3 ... 6