Author Topic: Horizontal banding  (Read 521 times)

John DeLonghi

  • Jr. Member
  • **
  • Posts: 92
    • View Profile
Horizontal banding
« on: February 06, 2018, 11:02:35 AM »
I got some horizontal banding today while running some tests. It was approx. 1.5 deg C if that makes a difference. I saw the same effect an all clips. Width/relative position of band changed when I changed vertical resolution.



What should I check?


tesla500

  • Krontech
  • Full Member
  • *****
  • Posts: 168
    • View Profile
    • krontech.ca
Re: Horizontal banding
« Reply #1 on: February 06, 2018, 04:26:57 PM »
That looks like the shutter line artifact. I think what happened is you changed the shutter speed and didn't do a black cal. Try again, making sure to do a black cal after any shutter speed change. This isn't such an issue at full horizontal resolution, but at reduced resolution it's important.

John DeLonghi

  • Jr. Member
  • **
  • Posts: 92
    • View Profile
Re: Horizontal banding
« Reply #2 on: February 07, 2018, 02:05:04 AM »
I definitely did a black cal after every change I made and this happened on every clip (about 20) with different resolutions and frame rates. I even turned the camera off and on twice to try and clear it.

Maybe I should have done a proper re-boot, but I thought it had cleared viewing on the built in monitor. Only when I got back and looked at all the clips on a bigger monitor could I see it affected all of them.

I've turned the camera on now and the band is still there, so is there anything you want me to do to try and figure out what's happened and how to avoid it happening in the future?

tesla500

  • Krontech
  • Full Member
  • *****
  • Posts: 168
    • View Profile
    • krontech.ca
Re: Horizontal banding
« Reply #3 on: February 07, 2018, 01:34:38 PM »
Does either the top or bottom of the band move when you move the shutter slider?

John DeLonghi

  • Jr. Member
  • **
  • Posts: 92
    • View Profile
Re: Horizontal banding
« Reply #4 on: February 08, 2018, 12:58:14 AM »
Yes it does.

It almost seems as though the black cal. setting is being forgotten some time after setting it.

I just did a black cal and left the camera on (not recording) and when I came back 5 minutes later the horizontal band had appeared again.

tesla500

  • Krontech
  • Full Member
  • *****
  • Posts: 168
    • View Profile
    • krontech.ca
Re: Horizontal banding
« Reply #5 on: February 08, 2018, 02:47:03 AM »
Interesting. Was the camera warming up during this time, or was it fully warmed up (at least 20min)?

John DeLonghi

  • Jr. Member
  • **
  • Posts: 92
    • View Profile
Re: Horizontal banding
« Reply #6 on: February 08, 2018, 04:10:30 AM »
It was at room temperature to start with and initially when I turned it on there was no band, but after maybe 5-10 mins being on the band appeared.

On Tuesday when I was outside, the ambient temperature was only just above freezing all day, if that helps at all.

JamesB

  • Newbie
  • *
  • Posts: 31
    • View Profile
Re: Horizontal banding
« Reply #7 on: February 08, 2018, 07:56:10 PM »
I tried to replicate the problem but after black calibration, it went away every time on my unit. Glad I checked this post as I was wrestling with the same issue.  If you accidentally change the shutter even a little with the scroll bar it may come back.  I also found that if you do two black calibrations a few minutes apart the banding goes much lower.    :)

John DeLonghi

  • Jr. Member
  • **
  • Posts: 92
    • View Profile
Re: Horizontal banding
« Reply #8 on: February 09, 2018, 01:48:05 AM »
I also found that if you do two black calibrations a few minutes apart the banding goes much lower.    :)

I'm confused by this statement. Can you explain in more detail please?

tesla500

  • Krontech
  • Full Member
  • *****
  • Posts: 168
    • View Profile
    • krontech.ca
Re: Horizontal banding
« Reply #9 on: February 09, 2018, 09:46:50 AM »
The amount of banding is effected by temperature. If you black cal the camera, then it warms up or the ambient temperature changes significantly, the banding will reappear. Make sure to black cal after the camera has reached a stable temperature, leave it running for about 20 minutes or so in the environment you'll be using it in before use.

For example, letting it warm up indoors, then taking it outdoors where it's cold will cause this to show up.

John DeLonghi

  • Jr. Member
  • **
  • Posts: 92
    • View Profile
Re: Horizontal banding
« Reply #10 on: February 09, 2018, 10:48:35 AM »
Will constant low temperature cause it? I had the camera on continuously on Tuesday, so it got as warm as it could but the ambient temperature was always very low.

If this is going to be an ongoing problem when using the camera outside, I'll have to do a black cal immediately before every shot.

tesla500

  • Krontech
  • Full Member
  • *****
  • Posts: 168
    • View Profile
    • krontech.ca
Re: Horizontal banding
« Reply #11 on: February 09, 2018, 12:46:19 PM »
Will constant low temperature cause it? I had the camera on continuously on Tuesday, so it got as warm as it could but the ambient temperature was always very low.

If this is going to be an ongoing problem when using the camera outside, I'll have to do a black cal immediately before every shot.

It's possible that constant low temperatures may be beyond what the stock calibration can handle, I will look into this. However, if doing a black cal just before the shot fixes it, the problem is not the calibration, it's just a change in temperature that occurred between the last black cal and the current shot.

John DeLonghi

  • Jr. Member
  • **
  • Posts: 92
    • View Profile
Re: Horizontal banding
« Reply #12 on: February 10, 2018, 10:26:21 AM »
Is there a sensor in the camera measuring temperature?

John DeLonghi

  • Jr. Member
  • **
  • Posts: 92
    • View Profile
Re: Horizontal banding
« Reply #13 on: February 11, 2018, 10:34:11 AM »
Today I put the camera in a fridge and got it down to 5 deg C.

Switched on and let it warm up a bit then did a black cal. The banding comes back immediately. The camera is still sitting here warming up to room temperature but already it will be warmer than it was when I had the initial problems last week outdoors.

I think this does indicate that constant cold temperatures is likely to cause banding which can't be removed by black cal (or at least not long enough to get a good shot).

Maybe the camera needs some sort of temperature control by varying the fan speed?  Outside temperatures in the UK are likely to be low for several weeks to come and this renders the camera unusable for me while this problem persists.

Is there a workaround you can suggest? If I taped up the ventilation holes would that be safe?

 

BiduleOhm

  • Newbie
  • *
  • Posts: 49
    • View Profile
Re: Horizontal banding
« Reply #14 on: February 11, 2018, 02:26:32 PM »
Maybe the camera needs some sort of temperature control by varying the fan speed?

The fan speed is already variable and controlled by the camera.

Is there a workaround you can suggest? If I taped up the ventilation holes would that be safe?

I can recall David recommending another member to do exactly that so it should be safe (maybe don't cover all the holes though).