Author Topic: Trying to synchronize video capture with external trigger  (Read 560 times)

Ormia

  • Newbie
  • *
  • Posts: 9
    • View Profile
Trying to synchronize video capture with external trigger
« on: March 16, 2018, 03:14:52 PM »
Hi Everyone,

I am trying to get Chronos 1.4 to start video capture upon detecting an external TTL signal connected to the Trigger I/O 1.
My National Instruments Data acquisition device is providing this TTL signal...high for 2 seconds.

The camera detects this TTL signal as I can see in the trigger settings menu, the status changes from 'lo' to 'hi' and then back down to 'lo'.
However, the camera only captures 1 image and stops recording. Can I get the camera to start image capture on 'hi' and then continue to do so for a specified duration (i.e. 2-3 seconds?)

Thanks,


Nikon1

  • Jr. Member
  • **
  • Posts: 71
    • View Profile
Re: Trying to synchronize video capture with external trigger
« Reply #1 on: March 16, 2018, 04:28:01 PM »
I dont know too much about that topic, but have you ever tried to interrupt that Signal from your device (like with a simple Swich or someting), so the Chronos gets multiple Signals?
Maybe it would take one Shot for every incoming Signal.
If it Works that way, maybe try triggering a Frequency Generator with the Signal of your Device. And then Feed The Chronos with the Signal from your Frequency generator.
Framerate would be Set then via Frequency.
Not sure about that, but maybe worth a try

tesla500

  • Krontech
  • Full Member
  • *****
  • Posts: 181
    • View Profile
    • krontech.ca
Re: Trying to synchronize video capture with external trigger
« Reply #2 on: March 16, 2018, 08:56:03 PM »
The best way to do this is to use the new beta software, see the thread in the Software Dev forum.

Set the record length to whatever you want in Record Settings->Record Modes, then set the trigger delay to 0% in Record Settings->Trigger Delay. Turn off Invert and Pullups in Trigger/IO settings, then start recording and leave the camera recording. Once your TTL event occurs, it will save from the point the TTL signal went high, for the duration specified in Record Modes.

I believe the camera may have been capturing only one frame because it was triggering immediately when you started recording, this depends on your settings however.

Ormia

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Trying to synchronize video capture with external trigger
« Reply #3 on: March 19, 2018, 06:25:28 PM »
Yes this works! Thanks!


pstest

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Trying to synchronize video capture with external trigger
« Reply #4 on: April 11, 2018, 01:41:31 PM »
The event may have been brief if using Triggering Exposure where pulse duration is 1/frame rate.
Check the frequency of your TTL signal so < frame rate.

chaosui

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Trying to synchronize video capture with external trigger
« Reply #5 on: July 14, 2018, 10:14:51 AM »

Set the record length to whatever you want in Record Settings->Record Modes, then set the trigger delay to 0% in Record Settings->Trigger Delay. Turn off Invert and Pullups in Trigger/IO settings, then start recording and leave the camera recording. Once your TTL event occurs, it will save from the point the TTL signal went high, for the duration specified in Record Modes.

If there is any method that the recording is off until the external signal comes that the camera starts to record and last for the predefined record lenght?