Author Topic: Software V0.3 RC1  (Read 566 times)

tesla500

  • Krontech
  • Full Member
  • *****
  • Posts: 168
    • View Profile
    • krontech.ca
Software V0.3 RC1
« on: May 03, 2018, 08:27:43 PM »
Here is the release candidate for V0.3, for those of you who want to try the latest and greatest. An updated manual is also attached to this post.

Keep in mind this software is still a release candidate. It has not gone through full validation yet, this software is generally stable but we don't recommend using this for any critical applications where it's not possible to recreate your shot. We recommend waiting for the final release for any applications that require guaranteed stability.


    ┌──────────────────────────────────┐
   ┌┘                                  └┐
   │     Chronos V0.3 RC1 Changelog     │
   └┐                                  ┌┘
    └──────────────────────────────────┘


Notable Changes (from V0.2.5):
- Colour reproduction is greatly improved, especially reds
- Keyboard behavior improved, text is now selected when you tap an edit box
- UI can be flipped, or set to display the main screen menu on the left side
- You can configure the "Unsaved video in RAM" popup when you hit the record button with an unsaved video in memory. It can be set to "Always", "If not reviewed" (default), or "Never". The previous behaviour was always "If not reviewed".
- Fixed bug in 0.2.5 beta that resulted in a small portion of saves failing (about 2%)
- Fixed bug where segmented record mode would produce many invalid segments

More notable changes (from V0.2):
- Trigger I/O's Trigger delay input was moved to the Trigger Delay screen.
- Added Trigger Delay screen and Record Modes screen, accessible from Record Settings.
- Black cal duration reduced by 10s to 15s or so at max resolution. (We still hope to make this much, much faster in a future beta.)
- Use any SD card. Previously, a class 10 SD card was required. You can now use slower cards. Of course, using a slower SD card means that videos save slower too.
- You can now auto-record after saving and auto-save after recording. This can loop.

Minutiae:
- Mark In and Mark Out have been renamed to Mark Start and Mark End, probably just until the video seek bar is made horizontal.
- Playback screen has 'region to be saved' marked. Each region saved is marked in a different color.
- The Enter key has been changed to say Apply, since you have to press it to apply your changes.
- The sliders on main screen the play screen have been made larger for ease of grabbing.
- There is now a Settings tab in the Util pages.
- Trigger IO window: The ratio between post-trigger frames and record length in frames is kept constant between resolution and framerate changes.
- Play → Settings: bitsPerPixel, maxBitrate, saved file framerate, format, filename and save location are now saved as soon as they are changed instead of when the Close button is pressed.

RC1 known bugs:
-On some cameras, a small number of recorded frames are corrupted (about 1 in every few thousand). Most cameras do seem to exhibit this problem. Fix is in progress, this post will be updated when a fix is available.
-The first few frames in saved videos are from the end of the recording


Installation instructions:
  • Unzip the Zip file into the root directory of a FAT32 formatted USB stick
  • This should result in a camUpdate folder in the root directory of the stick
  • Boot up the camera and insert the USB stick
  • Backup your calibration data. Tap "Backup calibration data" and wait for this to complete (about 5 seconds). The cal data is now backed up on the USB drive as cal_[serial number].tar
  • To install the update, tap Apply Software Update
  • A message box should pop up indicating the software update was found. Tap Yes to install the update.
  • The screen will go black, you may see a screen saying "updating", and the update will be installed. This will take about 30 seconds, potentially longer depending on the speed of the USB drive. There's no feedback that anything is happening, just give it time. The camera will restart at the end of this process
  • Done!

As always, let us know of any bugs you find, we'll get them sorted out as quickly as possible. We anticipate the fully validated V0.3 release in about a month.
« Last Edit: May 08, 2018, 09:58:29 PM by tesla500 »

gamerdonkey

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Software V0.3 RC1
« Reply #1 on: May 07, 2018, 02:10:55 PM »
I got the 0.3rc1 update and was playing with my Chronos and RAW output over the weekend. I've come across two issues that I didn't notice when I was running 0.2.5.

The first (and more minor) issue is that the first frame of all the videos that I output looks like the image below. I didn't do any in-camera h.264, so I don't know if it would appear in those. I also didn't notice it in preview or playback while working with the camera.



My second problem is that random frames in recordings are coming out corrupted like the ones below:





Frames before and after look fine. These also seem to be showing up in the preview and playback screens on the camera, though the picture below is from when I was able to reproduce the issue today and it looks a little different.



The problem seemed to arise when I changed resolution from 1280x720 to 800x480 after the camera had reached a warm temperature. That is how I was able to reproduce the issue today.

Thanks for your continued hard work on this project. The 0.3rc1 update has significant improvements! I have been able to work around these issues by manually deleting the problem frames, but I look forward to resolving the bugs more permanently.
« Last Edit: May 07, 2018, 02:18:18 PM by gamerdonkey »

John DeLonghi

  • Jr. Member
  • **
  • Posts: 92
    • View Profile
Re: Software V0.3 RC1
« Reply #2 on: May 08, 2018, 02:06:27 AM »
I got the same first frame issue with 0.3 RC1, but it's no big deal to edit out for now.

I haven't seen the corrupted random frames yet, but I did notice a colour shift in a few frames in one sequence I was unable to explain, so maybe that's related?

JamesB

  • Newbie
  • *
  • Posts: 31
    • View Profile
Re: Software V0.3 RC1
« Reply #3 on: May 08, 2018, 09:02:29 PM »
Got the same start frame corruption and occasional frames garbled.  I reverted back to the previous release as I need all frames to be free of artifacts for a shoot I'm working on.  Hopefully, this bug can be fixed soon so I can continue testing.

tesla500

  • Krontech
  • Full Member
  • *****
  • Posts: 168
    • View Profile
    • krontech.ca
Re: Software V0.3 RC1
« Reply #4 on: May 08, 2018, 09:51:19 PM »
Confirmed, duplicated it here as well. Looking into it now, will post an update in the main post above when we've fixed it.

nik282000

  • Newbie
  • *
  • Posts: 48
    • View Profile
Re: Software V0.3 RC1
« Reply #5 on: May 09, 2018, 08:53:47 AM »
Just a quick question about the update process. If I made an image of my current OS microSD card could it be used to roll back from 0.3 if I ran into problems? I'd like to test out the new colour handling but would also like a safety net. If so I shouldn't need to reload the calibration data correct?

tesla500

  • Krontech
  • Full Member
  • *****
  • Posts: 168
    • View Profile
    • krontech.ca
Re: Software V0.3 RC1
« Reply #6 on: May 09, 2018, 08:56:35 AM »
Just a quick question about the update process. If I made an image of my current OS microSD card could it be used to roll back from 0.3 if I ran into problems? I'd like to test out the new colour handling but would also like a safety net. If so I shouldn't need to reload the calibration data correct?

Correct, you can image the card and remiage it if you want to revert. You can also restore using the reference image on the Software Updates page on the website.

nik282000

  • Newbie
  • *
  • Posts: 48
    • View Profile
Re: Software V0.3 RC1
« Reply #7 on: May 09, 2018, 09:45:56 AM »
Awesome, thank you.

tesla500

  • Krontech
  • Full Member
  • *****
  • Posts: 168
    • View Profile
    • krontech.ca
Re: Software V0.3 RC1
« Reply #8 on: May 09, 2018, 01:16:40 PM »
im getting stuck in the backup calibration data please wait, its been several minutes and no buttons do anything, tried restarting several times and get the same?

Try a different flash drive, or maybe reformat your current one.

patrickrebstock

  • Jr. Member
  • **
  • Posts: 82
  • playing camera
    • View Profile
    • patrickrebstock.com
Re: Software V0.3 RC1
« Reply #9 on: May 09, 2018, 02:41:13 PM »
im getting stuck in the backup calibration data please wait, its been several minutes and no buttons do anything, tried restarting several times and get the same?

Try a different flash drive, or maybe reformat your current one.
reformat worked

patrickrebstock

  • Jr. Member
  • **
  • Posts: 82
  • playing camera
    • View Profile
    • patrickrebstock.com
Re: Software V0.3 RC1
« Reply #10 on: May 09, 2018, 02:47:09 PM »
can you do the segmented buffer with the auto save and record so you can shoot one clip and it will save half the buffer in the backround and then you can shoot the other half and then it saves? thinking for the water housing,
tested this am and so stoked for more jog wheel control and IQ improvements

using a 8-15mm canon with metabones xl speedbooster
https://www.youtube.com/watch?v=ZonxpIPXNqc&feature=youtu.be

patrickrebstock

  • Jr. Member
  • **
  • Posts: 82
  • playing camera
    • View Profile
    • patrickrebstock.com
Re: Software V0.3 RC1
« Reply #11 on: May 09, 2018, 04:04:45 PM »
Hey David, im not sure if its just me but the WB seems harder to use, i keep trying it on a white sheet of paper and getting weird colors, where I had an easy time doing it this on the old firmware when it wasn't as bright this am,


on a separate note:
When do you think Setting the Whiteballence by Kelvin temperature will be available?  I would say this is my number one reason for getting failed shots, i can't find anything to white balance off of, or the lens focal length makes it impossible either fisheye lens or 800mm telephoto, i would love to just set the WB to 5500k and be done with it, I would guess about 60% of my shots suffer because of having to do a custom WB

patrickrebstock

  • Jr. Member
  • **
  • Posts: 82
  • playing camera
    • View Profile
    • patrickrebstock.com
Re: Software V0.3 RC1
« Reply #12 on: May 09, 2018, 10:16:32 PM »
test this afternoon of the new firmware
the shot is close focused
https://www.youtube.com/watch?v=fR4xdJvB3Y0&feature=youtu.be

patrickrebstock

  • Jr. Member
  • **
  • Posts: 82
  • playing camera
    • View Profile
    • patrickrebstock.com
Re: Software V0.3 RC1
« Reply #13 on: May 10, 2018, 09:39:06 AM »
https://m.youtube.com/watch?v=Udd9BU96fqM&feature=youtu.be
Video of the wb maybe bug, after video I got a better wb off of the rocketbox of my car, but it is a bit rediculous
Loving everything but this should be improved as it seems to work worse than last version

Jeff_Dawson

  • Newbie
  • *
  • Posts: 1
    • View Profile
    • Insect Flight Group
Re: Software V0.3 RC1
« Reply #14 on: May 18, 2018, 02:25:54 PM »
Hi Forum

I'm wondering if this updated software release (when it's officially released) will have support for ethernet connectivity (I read it's being developed and is a high priority)?  The updated manual states that it's still pending.  Any insights would be appreciated.

I've just ordered a pair of cameras to do high-speed stereo kinematic reconstructions of insect flight... my rig (wind tunnel, etc.) means access to the SD card for offloading video will be awkward.  I did read that there is a script that allows monitoring of the SD card for new files then automatically sending them to a remote computer by SCP... additional information about that option would be appreciated (information beyond what is already on the forum, of course).

Can't wait for the new cameras to arrive!
J.