Author Topic: SDXC Card  (Read 205 times)

The_Wound_Channel

  • Newbie
  • *
  • Posts: 8
    • View Profile
SDXC Card
« on: July 06, 2017, 05:55:53 PM »
Is the Chronos not compatible with SDXC memory cards?  I bought a new 64GB card and the camera acted like it wasn't even there.

tesla500

  • Krontech
  • Jr. Member
  • *****
  • Posts: 72
    • View Profile
    • krontech.ca
Re: SDXC Card
« Reply #1 on: July 06, 2017, 07:10:13 PM »
It does support SDXC, I've used cards up to 128GB.

You probably have it formatted in some filesystem other than FAT32, most large SD cards come formatted exFAT which isn't yet supported. Windows (very annoyingly) won't let you format cards larger than 32GB as FAT32, so you need to use a 3rd pary application such as FAT32 Formatter. Let me know if this doesn't solve the problem

The_Wound_Channel

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: SDXC Card
« Reply #2 on: July 07, 2017, 08:32:52 AM »
That makes perfect sense, and you're right I tried to reformat to FAT32 and it wouldn't let me on Windows.

I'll try that program, thank you!

thebishop

  • Newbie
  • *
  • Posts: 25
    • View Profile
Re: SDXC Card
« Reply #3 on: September 26, 2017, 04:32:41 AM »
For anyone having trouble with large size SDXC (e.g. 128GB) on macOS, I succeeded using the tips from the following article:

https://www.michaelcrump.net/the-magical-command-to-get-sdcard-formatted-for-fat32/

The normal Disk Utility failed to format FAT32, even if it allowed me to try.

I haven't tried it with the camera yet (have not received delivery), but it looks like it works alright.

Code: [Select]
solid:~ jocke$ diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.3 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                 Apple_APFS Container disk1         500.1 GB   disk0s2

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +500.1 GB   disk1
                                 Physical Store disk0s2
   1:                APFS Volume Macintosh HD            337.3 GB   disk1s1
   2:                APFS Volume Preboot                 19.4 MB    disk1s2
   3:                APFS Volume Recovery                520.0 MB   disk1s3
   4:                APFS Volume VM                      2.1 GB     disk1s4

/dev/disk2 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        +3.0 TB     disk2
   1:                        EFI EFI                     209.7 MB   disk2s1
   2:                  Apple_HFS Time Machine Backups    3.0 TB     disk2s2

/dev/disk3 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *256.5 GB   disk3
   1:                 DOS_FAT_32                         256.5 GB   disk3s1

solid:~ jocke$ sudo diskutil eraseDisk FAT32 CHRONOS MBRFormat /dev/disk3
Password:
Started erase on disk3
Unmounting disk
Creating the partition map
Waiting for partitions to activate
Formatting disk3s1 as MS-DOS (FAT32) with name CHRONOS
512 bytes per physical sector
/dev/rdisk3s1: 500867584 sectors in 7826056 FAT32 clusters (32768 bytes/cluster)
bps=512 spc=64 res=32 nft=2 mid=0xf8 spt=32 hds=255 hid=2 drv=0x80 bsec=500989950 bspf=61142 rdcl=2 infs=1 bkbs=6
Mounting disk
Finished erase on disk3
solid:~ jocke$

GhostRider

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: SDXC Card
« Reply #4 on: September 26, 2017, 06:00:23 PM »
This free soft will format also ONLY in fat32.

http://www.ridgecrop.demon.co.uk/index.htm?guiformat.htm

Formatted my 128g SDXC perfectly.