Author Topic: Chronos V0.3.2-RC1  (Read 433 times)

skronstein

  • Krontech
  • Newbie
  • *****
  • Posts: 44
    • View Profile
Chronos V0.3.2-RC1
« on: July 25, 2019, 09:42:07 PM »
Here is Chronos 1.4 Software V0.3.2-RC1. Do not use this software version if you are capturing something that is not easily replicated.

    +----------------------------------+
   ++                                  ++
   |   Chronos V0.3.2 RC1 Changelog     |
   ++                                  ++
    +----------------------------------+


Notable Changes:
 - Automatic ADC calibration during black calibration, which should reduce column banding across a wider temperature range.
 - Add a storage tab to the util menu to view, eject and format the attached storage devices.
 - Speed boost at most resolutions, with a top speed of 1069fps at 1280x1024, and 40420fps at 320x96.
 - Configurable automated power-on and off depending on the AC adaptor status.
 - Option to disable the ring buffer when in segmented recording mode.

Minutae:
 - Factory black calibration is now user accessible from the Factory tab of the util window.
 - The software update button has been moved to the storage tab of the util window.
 - Shipping mode to disable power-on by battery until an AC adaptor is attached.
 - Add a watchdog to reboot the camera in case of a power-on boot failure.
 - Display descriptive error strings instead of number on failure.

Fixed Bugs:
 - Gated burst record mode may lock up after several trigger edges.
 - Gated burst record mode unreliable when trigger debounce is enabled
 - Memory leak in the M3 video coprocessors which could lead to a crash after lots of H.264 encoding.
 - Ignore video which was recorded during zero-time black calibration (which happens after changing resolution).
 - Stuttering issue on the playback window on new production LCD modules.
 - Fixed deadlock in camera when restoring user settings from external media.

Fixed since V0.3.2-beta-6:
 - Changes to focus aid or exposure aid (zebra stripes) would have no effect until resolution is changed.
 - Changes to exposure may be overwritten during black calibration.
 - Bad image quality at 336x120 resolution
 - Util window, storage tab - bottom of text cut off if device has multiple partitions
 - Factory black cal (black cal all resolutions) would get overridden by old user black cal, if a user had done their own black cal, even before.

Known Issues:
 - On the save file settings window, the bitrate as listed above the resolution may be lower than the actual bitrate, if Saved File Framerate is lower than 60fps

Updating Your Camera
====================
 - Extract the `.zip` file into the root directory of a FAT32 formatted USB drive.
 - Turn on your camera and insert the USB drive into the USB/eSATA combo port, not the one labeled 'OTG'.
 - From the main window, tap the `Util` button to open the utility window.
 - As a precaution, tap the `Backup Calibration Data` button on the utility window before starting the update.
    - When the backup is completed, a pop-up window will be displayed.
    - Tap the `Done` button to close the pop-up window.
 - From the utility window, tap the `Apply Software Update` button to begin the software update.
    - A warning message will be displayed, tap the `Yes` button to confirm and begin the update.
    - If a pop-up that says 'No software update found' is displayed, even when a USB stick containing the update in the correct location is connected, reboot the camera and try again.
 - During the update, the screen will go blank and an `Applying Update` message will be displayed.
 - After approximately 60 seconds, the update will be complete and the camera will restart.
« Last Edit: July 26, 2019, 02:53:06 PM by skronstein »

JamesB

  • Jr. Member
  • **
  • Posts: 56
    • View Profile
Re: Chronos V0.3.2-RC1
« Reply #1 on: July 26, 2019, 12:58:04 AM »
Great News!

Do we have to factory calibrate after applying this update or just use it as is?  Will test this weekend. Thank you!

skronstein

  • Krontech
  • Newbie
  • *****
  • Posts: 44
    • View Profile
Re: Chronos V0.3.2-RC1
« Reply #2 on: July 26, 2019, 01:38:49 AM »
Great News!

Do we have to factory calibrate after applying this update or just use it as is?  Will test this weekend. Thank you!

No, it's not necessary to factory calibrate after the update.  That feature really just does black cal for all of the standard resolutions.

JamesB

  • Jr. Member
  • **
  • Posts: 56
    • View Profile
Re: Chronos V0.3.2-RC1
« Reply #3 on: July 29, 2019, 12:00:09 AM »
Ok did some testing...

Everything works as expected with what seems improved column noise pattern reduction after calibration. It still requires camera warming up to get to a point where the calibration works pretty well, that is about 26 minutes warm up.
Fan goes faster when using AC power vs the battery, that is to be expected.

1 Bug Found: when using HDMI monitoring, you activate the focus asist function (peaking) on the camera and it slows to a crawl then image locks up and no motion is attained. Only fix is unplug the HDMI cable and things return to normal.  Camera refreshes signal and regular operation resumes.

It seems the cpu is overwhelmed when peaking is activated and HDMI is operating. Tried with a field monitor and an LCD viewfinder both showed the same problem,

Great job on the nice features like improved fps and storage info + format options, much appreciated!  :D

Ian

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Chronos V0.3.2-RC1
« Reply #4 on: July 30, 2019, 10:31:00 AM »
Hi all
I upgraded to this latest release as well and have experienced the same freezing/lack of response issue. In my case though I was messing around with a new lens which was heavy. I did not have an external monitor connected however the screen was rubbing against me as I messed around with the back focus adjustment. I didn't spot a pattern to it but it was doing it regularly. I tried one short recording whilst it was stuttering and that seemed to record ok. I have gone back to the beta in the mean time.

PaulBryanTV

  • Newbie
  • *
  • Posts: 41
    • View Profile
    • YouTube
Re: Chronos V0.3.2-RC1
« Reply #5 on: August 01, 2019, 01:28:27 PM »
Also had this freezing / lag issue.
Essentially slows the display to a crawl and makes it near unresponsive. No set pattern but focus peaking don't help!
No monitor involved either.

NiNeff

  • Full Member
  • ***
  • Posts: 109
    • View Profile
Re: Chronos V0.3.2-RC1
« Reply #6 on: August 02, 2019, 02:35:30 AM »
I tried a few things and I'm not having any stuttering or freezing issues on the new firmware. HDMI out works, focus peaking is not a problem. I'm letting the camera warm up a bit more now to see if I'm affected as well but so far it doesn't appear so.
Edit: I decided to test the "Restore Default Settings" option and it just displayed the shutting down screen for 20 minutes without progress. I had to do a hard reset, but it seems to work fine again. Probably not related and a non-issue for me as I'm not intending to revert to factory settings often.
« Last Edit: August 02, 2019, 03:16:02 AM by NiNeff »

skronstein

  • Krontech
  • Newbie
  • *****
  • Posts: 44
    • View Profile
Re: Chronos V0.3.2-RC1
« Reply #7 on: August 02, 2019, 01:11:42 PM »
Thanks for the feedback, guys. We've been able to reproduce both the focus peaking lag and the issue with reverting settings and are working on fixes.
About reverting settings - it's actually OK to shut down the camera right when the shutting down screen is displayed - no need to wait.

JamesB

  • Jr. Member
  • **
  • Posts: 56
    • View Profile
Re: Chronos V0.3.2-RC1
« Reply #8 on: August 04, 2019, 10:43:15 PM »
Thanks so much, looking forward to the peaking patch, I miss the feature big-time since my monitor peaking is not as accurate as the one you guys have been able top include in-camera!

JamesB

  • Jr. Member
  • **
  • Posts: 56
    • View Profile
Re: Chronos V0.3.2-RC1
« Reply #9 on: August 06, 2019, 11:24:53 PM »
Found another small problem.

In Firmware 0.3.1 the first frame of RAW DNGs was completely white and now Frame #1 is still full white and now new bug Frame #2 is the last frame of the recorded area instead of the second frame in the sequence as it should be. This is happening for all saved sequences. It is a minor inconvenience as I have to delete both 1,2 from the sequence before processing.

I did notice saving is much faster on SD cards for some reason on 0.3.2 RC1, I am getting 4.5-4.8fps instead of 3.8 as a maximum before.  Very welcome change!  ;D

skronstein

  • Krontech
  • Newbie
  • *****
  • Posts: 44
    • View Profile
Re: Chronos V0.3.2-RC1
« Reply #10 on: August 09, 2019, 03:32:41 PM »
Thanks for finding the bug.
I just tried to reproduce it on my camera, and it actually happened with all the save formats that I tried, not just DNG. Also, the frame was copied from whichever frame is currently visible, not necessarily from the end of the selected region.

JamesB

  • Jr. Member
  • **
  • Posts: 56
    • View Profile
Re: Chronos V0.3.2-RC1
« Reply #11 on: August 10, 2019, 01:11:46 AM »
Interesting, thanks for the testing the camera is getting better every day!