Author Topic: BUG REPORT -- Exposure slider not working properly at low framerates - UI Bug  (Read 695 times)

Nikon1

  • Hero Member
  • *****
  • Posts: 683
    • View Profile
Found another Bug, which i knew about for a While now, but never took the Time to clearly test.
 Now i tested it, here is the Result/ Description of the Bug.
 Test was done on Firmware 6.0, but older Firmware had the Same Basic Problem, didnt test that however, if it behaves exactly the Same.
 .
 So, as i used 60fps or some random lower Framerates occasionally, i noticed, that on 60fps, once you set the Framerate, the Exposure Slider will not work as intended anymore. The Thumbwheel still works, as does the Exposure Slider itself, but once you try to get to longer Exposure Times/ bigger Shutter angles, the UI starts to Glitch out. You can set maximum Exposure Time by dragging the Slider on the Touchscreen all the way up with your finger, but you will not be able to increase the Shutter angle With the Thumbwheel beyond a certain point. Once you are At Maximum Exposure however, you can use the Thumbwheel to go back down in exposure again, but not back up after that. Will still get stuck at the same Point, if you try to get back up to maximum exposure again.
 .
 As i knew that this was showing up on 60fps, and that it got way worse on even lower framerates, but still working fine at 100fps and seemingly random, i started my testing there.
 90fps Still worked fine, at 80fps it was already showing up, so i started my testing there, and tested every whole Number Framerate it would let me set (tried 1fps, but it wouldnt even let me set that, but just freaks out and set 1kfps, so lowest i did was 2fps).
 Now, i know that everything below 50fps is very impractical to use on this camera, and also recently learned that 60fps is supposed to be the lowest officially supported Framerate by Krontech, but as i noticed that there is some pattern to how it behaves, i included it in my test here anyways, as it might provide useful information in trying to figure out what is going on and help solve the Issue.
 Tested every Whole Number of Framerate from 90 to 2.
 Below follows a list with first the Framerate(-s) and the maximum Shutter angle i was able to set with the Thumbwheel at that framerate(-s).
 Test was done on an Chronos 2.1 at Full Resolution, 0db Gain.
 .
 .
 90 to 86fps       working as intended
 85 to 78fps       331
 77 to 70fps       299
 69 to 63fps       270
 62 to 57fps       244
 56 to 52fps       220
 51 to 47fps       199
 46 to 42fps       180
 41 to 38fps       163
 37 to 35fps       147
 34 to 31fps       133
 30 to 28fps       120
 27 to 26fps       108
 25 to 23fps       98
 22 to 21fps       89
 20 to 19fps       80
 18 to 17fps       72
 16fps               65
 15 to 14fps       59
 13fps               53
 12fps               48
 11fps               44
 10fps               39
 9fps                 36
 8fps                 32
 7fps                 29
 6fps                 24
 5fps                 21
 4fps                 17
 3fps                 12
 2fps                 1